Update from Microsoft: 'While the majority of customers and services are mitigated or seeing strong improvement across affected regions, we are continuing to work on tail-end recovery for remaining impacted customers and services. We have revised our mitigation time and are currently tracking toward full mitigation by 00:40 UTC on 30 October 2025, though we will communicate if mitigation is achieved sooner'. This equates to 11:40 AEDT.
Posted Oct 30, 2025 - 10:55 AEDT
Update
Update from Microsoft: 'We are seeing strong signs of improvement across affected regions and are tracking toward full mitigation' by 10:40 AEDT, 30 October 2025.
Posted Oct 30, 2025 - 10:28 AEDT
Monitoring
Incident Details: Impact to Microsoft reliant services due to a Microsoft outage. This incident is impacting service availability and may cause interruptions or delays in normal operation.
Incident Start: 03:00 AEDT , 30 October 2025 Estimated Resolution Time: 10:40 AEDT, 30 October, 2025 Current Status: Microsoft has deployed a fix and is monitoring recovery.